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Copyrights 
XML Pro User Guide Copyright 1999 Vervet Logic LLC. All rights reserved. 
 
No part of this documentation may be reproduced, transmitted, transcribed, stored in a retrieval system, or 
translated into any language, in any form by any means, except as provided in the license agreement 
governing the computer software and documentation or by prior written permission of Vervet Logic, LLC. 

XML Pro Samples 
Vervet Logic permits you to edit, manipulate, and change graphics, HTML code, XML code, and other 
text in XML Pro samples. The sample code is solely for tutorial use and for no other purpose. Vervet 
Logic has no warranty, obligation, or liability for the sample contents. 

Trademarks 
Vervet Logic, the Vervet Logic logo, and XML Pro are trademarks of Vervet Logic, LLC., registered in 
the U.S. and other countries. 
 
Other brand and product names are trademarks of their respective owners. 

How to contact us 
Technical support questions and suggestions for XML Pro can be directed to Vervet Logic as follows: 
 
Vervet Logic 
501 North Morton, Suite #211 
Bloomington, IN 47404 
 
Phone: (812) 856-5270 
Fax: (812) 855-4506 
E-mail: support@vervet.com 
WWW: http://www.vervet.com/support/ 
 
When contacting Vervet Logic, please specify the product version number, as well as your computer’s 
operating system and version. Before contacting technical support, please refer to the troubleshooting 
chapter of this manual. 
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Preface 
Welcome to the XML Pro Version 2.0. This user guide tells you how to install XML Pro, and edit, create, 
view, and validate XML documents. 

Audience 
This user guide is written for beginning to intermediate computer users. You should be somewhat familiar 
with document editing concepts and have some familiarity with XML. If you are not familiar with XML, 
you may want to start with (something) also included on the same CD as this manual. 

Requirements 
Installation of XML Pro 2.0 requires the following: 
Officially supported platforms: Windows 95/98/NT, Linux, Solaris  
Unofficially supported: Any platform with a Java 2 Virtual Machine 
All Systems: JRE 1.2 or Java 2 (JDK 1.2.1) 
Windows: Pentium 166MHz 
 64MB RAM 
 25MB Hard Drive Space (Installed) 
 75MB Hard Drive Space Free for Installation 
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Chapter 1: Installation 
This chapter contains instructions for installing and uninstalling XML Pro. 

Installation of XML Pro 
To install XML Pro in Windows: 
 
1. Insert the XML Pro CD in your CD-ROM drive, and in the My Computer folder, click on the icon for 

your CD-ROM drive. 
2. Click on the Install-XMLPro. 
This launches an InstallShield installer which automates the installation. First, XML Pro is installed. You 

are given options as to where it will be installed; the default location is c:\Program Files\XML Pro. 
After the installer finishes installing XML Pro, it will install the Java 2 Runtime Environment v1.2.1. 

You must install this to run XML Pro. If you have already installed the JRE v1.2.1 previously, you 
can cancel this part of the installation. 

3. After installation, launch XML Pro from the XML Pro program group in the Start menu. The first 
time you launch the program, you must register it by filling in your name, company, and registration 
code.  The code is found on the XML Pro CD case if you purchased the CD; it was sent to you via 
email if you purchased the downloaded version. 

 
To install XML Pro in a UNIX OS: 
 
1. You must first obtain a Java 2 VM for your UNIX platform. To download a copy of the JRE or JDK, 

visit http://www.javasoft.com and follow Sun’s instructions for obtaining and installing the latest Java 
software for your machine. 

2. Mount the XML Pro CD-ROM. In the UNIX directory, there is a compressed tar file called 
xmlpro2.0.zip To install, simply uncompress this archive. 

Uninstalling XML Pro 
To remove XML Pro from a Windows machine, select the Add/Remove Programs control panel (found in 
Control Panels, in the Settings submenu of the Start Menu.) Select XML Pro from the list of installed 
programs, and click the Add/Remove Programs button. You will then be prompted if you wish to remove 
the program, and it will be deleted from your system, along with any other related files. 
 
You can also remove the Java 2 Runtime environment using the Add/Remove Programs control panel. 
However, you may wish to keep this installed to run other Java applets and applications in the future. 
 
To remove XML Pro from a UNIX machine, simply delete the xmlpro.jar file and the other included XML 
Pro files. 
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Chapter 2: Basic File Operations 
XML Pro supports all of the standard file operations: New, Open, Close, Save, Save As, and Print. You 
are probably familiar with how all of these functions work, however there are some differences that are 
directly related to XML, for example, specifying a root element for a new document. Here's a rundown of 
File Operations and their support in XML Pro. 

Creating New Documents 
To create a new document in XML Pro, simply select New from the File menu. XML Pro will then 
prompt you to enter the name of the Root Element for your document. Since the foundation of an XML 
document is the root element, a new document cannot be created until you specify the name for your root 
element.  
 
The New Document dialog also enables you to enter a new character encoding type. By default, Encoding 
is set to UTF-8, an encoding of Unicode into 8-bit characters, which essentially provides the ASCII 
character set. You can also set this value to UTF-16. EUC-JP, or any other character set that is used by 
your specific application. 
 
Once you have input the root element name, the document will be created, with the root element in the 
document tree view. You can then begin editing the document contents, adding elements, associating a 
DTD, and so forth. 

Opening Files 
Selecting Open from the File menu will launch the Load Document dialog box. Here you can navigate 
your local or network file system to open documents with XML Pro. Selecting a file and clicking Open 
will bring the document into XML Pro for editing. 

Closing Files 
The currently open document in XML Pro may be closed by selecting Close from the File menu. This 
option will close the document, but will not exit the XML Pro application itself, allowing you to create a 
new document, or to open a new one. If the document you are currently working on has had changes made 
to it that have not been saved, XML Pro will first ask you if you would like to save the file before closing. 
This can help prevent the accidental loss of data by inadvertently closing a file that has not been saved. 

Saving Files 
XML Pro features the standard Save and Save As options. Save will simply save the currently open 
document with the current file name and in the same location the file was opened from. If the document is 
a new document, you will be prompted to specify the location and name to save the file under. The Save 
As option allows you to save the currently open document under a different name, or to a new location.  
 
If you open an existing document, and then choose Save As to relocate or re-name the document, keep in 
mind that unless you also choose Save, the original document will still exist in its original location and 
form. 

Printing Files 
XML Pro supports printing for XML files to local or network printers through your operating system’s 
print dialog. Selecting Print from the file menu will launch the print dialog, and present you with various 
options for printing, depending on your operating system and default printer type. See the documentation 
for your operating system and printer drivers for more information. 
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Editing Operations 
XML Pro supports standard editing options on the Edit menu: Undo, Cut, Copy, Paste, and Find. 
However, XML Pro does not support editing functionality in all windows. You can use Cut, Copy, and 
Paste editing operations within the text editing pane, or with elements in the document tree and their 
children. To add and remove items from the document tree, you can also use the appropriate tool from the 
Tools menu, or by right-clicking on the item.  

Undo 
The undo command reverses the actions of the last editing operation. Note that only one level of undo is 
available; if you perform two editing operations, you will be unable to undo the first operation. 

Cut 
The Cut command functions within the Text Editing Pane, and within Attribute text fields. Cut will 
remove the selected text, storing the text in the clipboard for later use. Once text has been cut, it can be 
inserted into another location in the document using the Paste command.  
 
It is important to note that Cut only retains one level of text. That is, if you cut a piece of text, and then 
select a new piece of text, and cut it, the first piece of text will be lost. Only the contents of the last Cut 
operation can be pasted into the document with the Paste command.  

Copy 
The Copy command will copy the selected text to the clipboard without removing the selected text from its 
original location within the document. This can be used to duplicate information in various locations. 
Once the selected text has been copied, it may be inserted into the document at a new location by using the 
Paste command.  

Paste 
The Paste command can be used in conjunction with both the Cut and Copy commands. Once a selected 
piece of text has been copied, or cut into the clipboard from XML Pro or other applications on your 
computer, Paste can be used to insert the text into the document at the current cursor location. Paste can 
be used multiple times to repeat text in multiple locations within the document. 

Find 
The Find option will open the Find dialog, which allows you to search the currently open document for 
the occurrence of a word or phrase. Once the text being searched for has been entered in the Text to Find 
field, you may click on the Find Next button to locate the text within the currently open document.  
 
You can also limit your search with the Options group box. By default, the All radio button is selected, 
which searches all of the currently open document. Click Element Names, Text Nodes, Attribute 
Names, or Attribute Values to limit your search to text within those values. 
 
If the word or phrase cannot be found, you will be alerted by a dialog, and the Find box will be closed. 
However, if an occurrence is found, the Find dialog will remain open, and you may continue to search for 
other occurrences by clicking on the Find Next button again. Repeatedly clicking Find Next will continue 
to traverse through the document until no more occurrences of your search term can be found.  
 
The find process begins searching the document from the beginning of the document tree.  
 
By default, Find in XML Pro is not case-sensitive. However, by clicking the Match Case option in the 
Find dialog, you can search for the exact match of your search term, including case. 
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Chapter 3: Using XML Pro Features 
The foundation of the XML document is the element, and XML Pro has many features that are geared 
towards making the creation, deletion and management of elements and their attributes simple and 
intuitive. These features include the Element Wizard, a management tool that enables you to create and 
delete elements, and the document tree view, which enables you to see the structure of the document, and 
how elements in the document relate to each other. Additional features, such as the Element Palette enable 
you to easily review available elements and to insert them into the document. The Attribute Wizard allows 
you to customize elements, and provide more information about them. And the Entity Palette enables you 
to insert entities defined in an associated DTD. 

The Element Wizard 
The Element Wizard is a visual tool within XML Pro, which can be used to create and remove element 
types for possible inclusion into the current document. When used in conjunction with a DTD, the 
Element Wizard will only display elements that are defined by the DTD, and will not allow elements to be 
removed. However, if the DTD allows the creation of new elements, then the Element Wizard may still be 
used to create new element types(and remove those new element types) for the document.  
 
The Element Wizard can be opened from the Toolbar, or from the Tools Menu. When opened, the Wizard 
will look like this:  
 
 

 
The Wizard consists of three primary components: a list of the currently defined elements, a text field for 
naming new elements, and the buttons that define the operations that can be performed on elements.  

Creating Elements 
New Element types can be created using the Element Wizard, and those element types will then be 
available to add to your document. To create a new element type: 
 
1. Launch the Element Wizard from the Toolbar or Tools menu.  
2. Enter the element name in the New Element Name field. Element names are case sensitive, so be 

sure to keep that in mind when creating new element types.  
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3. Click Add to create the new element type.  

Deleting Elements 
To delete an existing Element type:  
 
1. Select the Element type you wish to delete from the list of Elements shown.  
2. Click Remove to delete the element.  
 
Removing an Element from within the Element Wizard will remove the Element from your document 
entirely, including any information that is currently defined in existing elements. Because this option 
removes the Element entirely, you will be prompted to confirm that you really do want to remove the 
Element before proceeding. Once you click OK, the Element type, and any instances of this Element Type 
in your document will be completely removed.  
 
When you are finished creating and removing the element types for your document, click Close to return 
to the editor and continue editing your XML document.  

The Element Palette 
The Element Palette is a floating window that shows a list of all the available element types for the current 
open document.  
 

 
 
Elements displayed in the Element Palette are sorted in alphabetical order. However, if you have elements 
that are defined in a DTD, and then you create new elements, the element types which are defined within 
the DTD will be displayed first, sorted alphabetically. Following the DTD defined elements will be any 
custom elements, grouped together and also sorted alphabetically.  

Inserting Elements with the Element Palette 
To insert an Element listed in the Element Palette into the current document, first select the insertion 
point for the new element in the tree view of the document. Next, select the element type you want to add 
from the Element Palette, and click Insert. The new element is added to your document.  
 
Keep in mind that if you are working with a DTD, and have selected Available Elements Constrained by 
DTD on the options menu, the element that are shown in the Element Palette will change depending on 
where in the document you are trying to insert the new element.  
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Elements in the Document 
In addition to the Element Wizard and the Element Palette, XML Pro also has several features which 
allow you to work directly with the elements inside the tree view. You must use the Element Wizard to 
create and remove element types, however, individual instances of each element can be added directly to 
the tree.  

Inserting Elements in the Document 
In addition to inserting elements using the Element Palette, you can also insert elements from directly 
within the document tree view. To insert an element within the tree:  
 
1. Right click on the insertion point within the tree view.  
2. From the Pop-up menu, select the Add Element sub-menu, and then highlight the element you wish 

to insert. The Add Element sub-menu is currently limited to displaying 15 elements. If your document 
contains more then 15 element types, you will need to use the Element Palette to display all of the 
available element types.  

3. Release the mouse button, and the new element is inserted.  

Deleting Elements in the Document 
Element types may only be removed through the Element Wizard. However single occurrences of an 
element within the document can be deleted in one of two ways:  
 
1. Select the element to be deleted within the document tree view.  
2. Select Delete Element from the Tools menu.  
or  
3. Right click on the element to be removed, and select Delete from the Popup menu.  
 
The root element of a document cannot be deleted.  
 

Moving Elements 
Elements that are shown in the document tree view can be repositioned relative to other elements in one of 
three ways:  
 
1. Right click on the element to be moved, and select Move Up or Move Down from the Pop-up menu.  
2. Select the element to be moved, and then choose "Move Element Up" or "Move Element Down" from 

the Tools Menu.  
3. Select the element to be moved, and use the up and down arrows on the toolbar to reposition the 

element. 

The Attribute Wizard 
Attributes allow you to further customize elements to provide information about the element. When 
working with elements specified within a DTD, an element's attributes will be defined within the DTD. 
When working with elements not specified in a DTD, however, the Attribute Wizard can be used to assign 
attributes to elements, and to remove attributes from elements.  
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The Attribute Wizard provides a graphic means for assigning attributes to elements, and removing 
attributes from elements. The interface is shown below:  
 
 

 
On the left is the list of element types that are currently available in the document, either as defined in the 
document's DTD or added in the Element Wizard. When an element type is selected from this list, the 
attribute types that are currently assigned to that element type are shown on the right. An element type 
may contain any number of attributes. If that element type is specified in a DTD, the attributes will be 
defined within the DTD, and may not be modified using the Attribute Wizard, although they may be 
viewed.  

Creating New Attributes 
To create a new attribute for an element type:  
 
1. From the Tools menu, select the Attribute Wizard.  
2. Select the element type to which you want to add an attribute.  
3. Enter the attribute name in the New Attribute Name field. Attribute names are case sensitive, so 
“type" will be treated differently from "TYPE".  
4. Click Add, and the new attribute type will appear in the Attributes list on the right. The Attribute is 
now available for all elements of the selected type. When you return to the document and select the 
element, the new attribute will appear in the Attributes Pane within the Editor.  

Deleting Existing Attributes 
To delete an exiting attribute type:  
 
1. From the Tools menu, select the Attribute Wizard.  
2. Select the element from the Elements list, and then select the Attribute you wish to remove from the 

Attribute lists.  
3. Click Remove to remove the attribute.  
4. You will now be prompted to confirm that you do indeed want to remove the attribute type. Because 

removing the attribute type will delete all occurrences of the attribute from your document, including 
any values that might be assigned to the attribute, you should be absolutely sure you want to remove 
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the attribute. Once the attribute is removed, old values will be lost. If you do wish to remove the 
attribute, select OK and the attribute will be removed.  

Attributes with DTDs 
When you are working with a document that has an DTD associated with it, the attributes for elements 
defined within the DTD cannot be modified via the Attribute Wizard. This is due to the constraints placed 
on the document through the DTD.  

The Entity Palette 
Because Entities are defined within a document's DTD, XML Pro does not offer any method to create and 
destroy actual entities. However, you can list the Entities that are available to a document, and insert 
Entities defined in the DTD into a document with XML Pro.  
 
The Entity Palette is a separate floating window that can be hidden or shown through the Show Entity 
Palette option, found in the Options Menu. The Entity Palette shows a list of the Entities that have been 
defined in the DTD, as shown below:  
 

 
 
The Entity Palette can then be used to see the available Entities, and to insert them into the document.  

Adding an Entity to the Document 
Entities can be added to the current document in one of two ways:  
 
1. After selecting the insertion point in the document, you can select the Entity you would like to insert 

from the Entity Palette, and click Insert. This will insert it into the document below the currently 
selected item.  

2. You can also right click on the item you wish to insert the Entity below, and from the Pop-up Menu, 
select Add Entity. Under the Add Entity “sub-menu, you will find another listing of the available 
Entities, select the entity you wish to add and release the mouse. Only the first 15 entities will be 
available via this method.  

Removing an Entity from the Document 
There are two ways to remove an Entity from the document:  
1. Right click on the Entity you wish to remove, and select Delete. This will remove that single instance 

of the Entity from the document.  
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2. Select the Entity you wish to remove, and from the Tools menu, select Delete Element. This will also 
delete the instance of the Entity from the document.  

Neither one of these methods will affect the availability of the Entity to you in the Entity Palette, because 
Entities are defined within the DTD.  
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Chapter 4: XML Pro Editing Features 
Several tools are available for managing items in addition to elements in your document. You can also 
insert, remove, and change comments, CDATA, PCDATA, and change Attributes within your documents. 

Inserting Comments 
XML Pro supports XML Comments. XML Comments are represented in the document tree with the 
Comment Icon and Label. The contents of the Comment can be edited in the Text Editing pane of the 
main window. Comments can be added to a document by right clicking on the insertion point, and then 
selecting "Add Comment" from the Pop-up Menu.  

Removing Comments from the Document 
There are two ways to remove a Comment from the document:  
1. Right click on the Comment you wish to remove, and select Delete. This will remove the Comment 

from the document.  
2. Select the Comment you wish to remove, and from the Tools menu, select "Delete Element". This will 

also delete the Comment from the document.  
 
Caution should be used when removing Comments, because they are defined in the document, so once a 
Comment is removed and the document is saved, it will no longer be available. 

Inserting CDATA 
XML Pro supports CDATA in XML documents. CDATA is represented in the document tree with the 
CDATA icon and label, and the contents of the CDATA element are not shown in the tree. Once a 
CDATA item has been added to the tree, the contents can be edited in the Text Editing pane of the main 
window. CDATA can be added to a document by right clicking on the insertion point, and then selecting 
"Add CDATA" from the Pop-up Menu.  

Removing CDATA from the Document 
There are two ways to remove CDATA from the document:  
 
1. Right click on the CDATA you wish to remove, and select Delete. This will remove the CDATA from 

the document.  
2. Select the CDATA you wish to remove, and from the Tools menu, select Delete Element. This will 

also delete the CDATA from the document.  
 
Caution should be used when removing CDATA, because it is defined in the document, so once it is 
removed and the document is saved, it will no longer be available.  

Inserting PCDATA 
XML Pro features robust support for PCDATA in document. Since many documents contain a great deal 
of content contained in PCDATA, XML Pro features are designed to maximize efficiency and flexibility 
when working with PCDATA.  
 
XML Pro support viewing PCDATA items as icons in the tree view, allowing you to see the overall 
structure of the document easier, or to toggle to viewing the text content of PCDATA items within the 
tree, allowing you to see the document context.  
 
PCDATA can be added to a document by right clicking on the insertion point, and then selecting Add 
PCDATA from the Pop-up Menu.  
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Removing PCDATA from the Document 
There are two ways to remove PCDATA from the document:  
 
1. Right click on the PCDATA you wish to remove, and select "Delete". This will remove the PCDATA 

from the document.  
2. Select the PCDATA you wish to remove, and from the "Tools" menu, select "Delete Element". This 

will also delete the PCDATA from the document.  
 
Caution should be used when removing PCDATA because it is defined in the document, so once it is 
removed and the document is saved, the deleted PCDATA will no longer be available.  

Editing PCDATA 
To edit the text content of PCDATA, simply click on the PCDATA in the tree view. This will load the 
content of the PCDATA into the Text Editing pane of the editor, where you can type additional text, or 
cut, copy and paste text and information into the PCDATA.  

Viewing PCDATA in Context 
In order to help you view the content of the XML document, and to put all of the elements of the 
document into context, XML Pro features the ability to view the actual text of PCDATA in the tree view 
of the document. From the Options Menu, selecting View PCDATA Text in Tree will cause XML Pro to 
display the actual text content of PCDATA items in the tree view, so the document's content will be 
apparent as well as the document's structure.  
 
NOTE: This option should not be used with documents that contain large amounts of PCDATA.  

Editing Attributes 
When you are editing a document in XML Pro, and you click on an element in the tree view that has an 
assigned attribute, the attribute will appear in the Attribute Pane of the Editor. From the Attribute Pane, 
you can enter, delete, or edit the values that have been assigned to element attributes in your document. 
You may also use the cut, copy, and paste editing features within the Attribute Pane when working with 
attribute values.  

Assigning Values to Attributes 
To assign a value to an attribute:  
1. Click on the element with the attribute. The attribute appears in the Attribute Pane.  
2. Enter a value for the attribute in the text field next to the attribute name. There is no confirmation 

button; Once you have entered a value, if you select another element, the value will be committed to 
memory. If the attribute is specified in the DTD as enumeration, the fixed choices will be presented 
within a drop-down list box.  

How Attributes are Written 
When you create attributes for an element, the attribute will always appear in the Attribute Pane when that 
element is selected in the tree view. However, you do not need to assign a value to all instances of that 
attribute in all elements. Only attributes that have values assigned will be written to the final XML Code. 
This prevents your code from becoming cluttered with empty attributes which are not necessary to specify. 
To preview what attribute values are being written, you can use the View XML feature from the Tools 
Menu. Also, if you delete an attribute from the Attribute Wizard, it deletes all instances of the attribute 
throughout the document. 
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Viewing Attributes in the Document Tree 
XML Pro has the ability to display attributes for elements in the Attribute Pane, when an element is 
selected. However, to view all of the attributes for all element within the tree view, you can select the 
"View Attributes in Tree" option from the Options menu. When selected, this option will display an 
element's attributes adjacent to the element in the document tree view, to give you a better sense of the 
attribute's values in context. 
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Chapter 5: XML Pro User Options 
The XML Pro Options Menu features a number of options for customizing the behavior of XML Pro's 
interface and features, allowing you to tailor XML's features to the way you work. All of the options for 
XML Pro are toggled on and off through the menu, and are marked as on with a check mark that appears 
next to the option when it is enabled.  

View PCDATA in Tree 
This option allows you to view the contents of PCDATA in context in the tree view. When this option is 
enabled, the actual text content of the PCDATA will be displayed in the tree view, allowing you to read 
the document while still retaining its structure. When this option is disabled, PCDATA will be 
represented in the tree only by the PCDATA icon, allowing very large documents to be traversed more 
easily, while still preserving the overall document structure.  

Show Attributes in Tree 
This option allows you to toggle on and off the display of element attributes within the document tree 
view. When this option is enabled, an elements attributes are listed in the tree, adjacent to the element. 
When this option is off, attributes are not visible in the tree, but are still visible in the Attribute section of 
the editor.  

Show Element Palette 
This option allows you to show or hide the Element Palette. The Element Palette allows you to see all of 
the element types available to a document, and to insert them into the document from the Element Palette.  

Show Entity Palette 
This option allows you to show or hide the Entity Palette. The Entity Palette allows you to view all of the 
Entities that are available in a document, and to add them to the document as well.  

Available Elements Constrained by DTD 
This option allows you to constrain the elements that are available for insertion into the document based 
on the contents of the file's associated DTD. This can be used to help guide you into using the correct 
elements in the document. However, this does not prevent you from creating an invalid XML document.  
 
What the Available Elements Constrained by DTD option does is scan the DTD, and when an element is 
selected, you are only allowed to insert items under that element as they are specified within the DTD. 
However, the feature does not account for the ordering of elements, and the feature can be disabled, both 
of which can lead to creating an invalid XML document.  
 
This feature should be viewed as a helpful guide for promoting the creating of valid XML when used with 
a DTD, however all documents created with a DTD should be fully validated using the Validate feature 
before saving. 

Viewing the XML code  
XML Pro allows you to preview the actual XML Code that the program generates and writes out to your 
XML file. This feature is similar to the View Source feature found in the Netscape and Internet Explorer 
browsers, and allows you to see the text representation of your document structure.  
 
To access this feature, select View XML from the Tools Menu. This will open a text box that contains the 
contents of the XML file, exactly as it will be written to the file on your hard drive when you save the 
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document. When you are finished reviewing the code, you can close the View XML window by clicking 
the close box or clicking OK.  

Viewing the DTD 
If your document is attached to a DTD, XML Pro allows you to view the DTD. Select the View DTD 
option from the Tools Menu, and the DTD is displayed in a text box, similar to the View XML option. 
When you are finished reviewing the DTD, you can close the View DTD window by clicking the close box 
or clicking OK. 
 
The View DTD option is not available when the current document is not attached to a DTD. 
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Chapter 6: XML Pro Validation Features 
XML Pro supports XML documents with or without Document Type Definitions (DTDs). A document 
may be opened into XML Pro with a DTD already assigned, or it may be opened without an assigned 
DTD, and then a DTD may be associated with the document. XML also supports full validation for XML 
documents with DTDs. 
 
XML Pro supports the following features with XML and DTDs:  

Associating DTDs with documents 
 
XML Pro features the ability to associate a DTD with an existing XML document, or to remove the 
association of a DTD with an existing document. DTD association is performed by selecting the Associate 
DTD option from the Tools menu. This will open the Associate DTD dialog, which contains three fields: 
Name, SYSTEM, and PUBLIC. 
 
The Name field in the Associate DTD dialog is not user-definable. In accordance with the XML 1.0 
Specification, the name of the associated DTD actually corresponds to the DOCTYPE in the tag which 
specifies the DTD association in the XML file. This DOCTYPE must match the name of the root element 
in your document, so this will be determined automatically.  
 
The location of the DTD is specified in the SYSTEM text field. This is to correspond with the convention 
for specifying the location of DTDs within the XML document itself. The location of the DTD can be:  
 
1. A file name. If this is the case, the DTD and XML document must occupy the same directory.  
2. A file URL. If this is the case, you must use the "file:/" descriptor, and provide the full path to the 
3. location of the DTD.  
4. A WWW URL. For example, "http://www.myserver.com/mydtd.dtd".  
 
The Public field corresponds to the value of the PUBLIC attribute in the DOCTYPE element that 
defines the DTD associated with the document.  
 
Documents with existing DTDs may be opened within XML Pro without any advanced preparation, 
provided the DTD and the DTD specification are consistent with XML 1.0. The DTD will need to be 
available to XML Pro in the directory or location specified within the XML document. If the specified 
DTD cannot be found, XML Pro will fail to load the XML document.  
 
Similarly, XML Pro will not load an XML document if the associated DTD contains errors. If the DTD 
for a document is not valid, XML Pro will generate an error, and also provide the line number of the error 
to aid in troubleshooting the DTD.  
 
Upon loading a document that has a DTD pre-assigned, XML Pro will automatically validate the 
document. If it encounters any errors during the initial validation process, XML Pro will generate an error 
indicating the nature of the problem, and also highlight the item in the document tree view. You should 
correct the problem and repeat the validation process until the document is verified as being valid before 
continuing to edit the document within XML Pro.  
 
In specifying the location of the DTD associated with an XML file, XML Pro can process relative paths 
for DTDs and also URLs. However, the DTD must be present in the specified location in order for XML 
Pro to correctly process the DTD and to load the XML document.  
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Removing a DTD Association 
If you wish to remove the DTD association from the current XML document, you can do so in the 
Associate DTD dialog. Simply open the dialog, and click the Remove button. This will remove the DTD 
association.  
 
NOTE: Any changes made to the DTD Association will not take affect until the document is saved and 
reloaded.  

Elements and DTDs 
When using a DTD in conjunction with a document, XML Pro will prohibit the alteration of specified 
element types using the Element Wizard. Additionally, XML Pro has an option, Available Elements 
Constrained by DTD, which places limits on available elements based on the DTD.  
 
The Available Elements Constrained by DTD option will limit the elements that may be inserted into the 
document at any given location according to what elements the DTD will allow to be placed there. This 
can aid you in creating valid XML documents. However, care should be taken, since this option makes no 
attempt to restrict element order, which also could cause a document to be invalid. While the option 
provides a safeguard, it is not foolproof, and documents should still be validated before saving.  

Validating the Document 
Documents can be validated by selecting Validate from the Tools menu, or by clicking on the Validate 
button on the toolbar. When the validation process begins, the contents of the current XML document will 
be checked against the constraints specified in the associated DTD, to ensure that the format and content 
of the document conforms to the specifications of the DTD.  
 
If XML Pro encounters an error during the validation process, an error message will be generated. The 
message indicates the nature of the error encountered, and XML Pro will highlight the item that generated 
the error in the document tree view. Upon generating the error, the validation process will stop, and allow 
you to correct the error. Once the error is corrected, you can attempt to validate the document again, 
repeating the process until the validation process is successful with no error messages.  

Errors with the DTD 
XML Pro recognizes two types of errors with DTDs:  
 
1. A missing DTD. If XML Pro cannot find the associated DTD, and error will be generated, and the 

XML file will fail to load.  
2. DTD syntax errors. If XML Pro is unable to correctly parse the associated DTD due to an error in the 

DTD file, an error message will be generated. The error message indicates the nature of the error, if 
possible, and also give a line number, so that the DTD may be corrected before attempting to open the 
document again.  

Handling Invalid Documents 
XML Pro will open documents which have an associated DTD, but which are invalid. XML Pro will not 
open an XML document that is not well-formed. Upon opening a document that is not valid, XML will 
generate an error message indicating the problem. You should correct the problem and successfully 
validate the document before editing it within XML Pro.  
 
XML Pro will also allow invalid documents to be saved, but it will first prompt you to make sure you are 
aware that the document has not been validated. This feature allows you to work on complex documents 
over a period of time, especially when troubleshooting a document. However, you should always be careful 
when saving an invalid document, as it may cause problems with other applications. 
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Chapter 7: Troubleshooting XML Pro 

Problems with Installation 
If you can’t get XML Pro 2.0 to install or run, check the following problems: 
 
• Is there enough free disk space? - Although XML Pro and the JRE 1.2 take about 25 MB of disk 

space, you must have 75MB of space to run the Windows installer. Ensure you have enough space 
before you begin. 

• Do you have a Java 2 VM? - The Windows installation includes the Java Runtime environment 
1.2.1, but UNIX users must first install the JRE or JDK. Because XML Pro 2.0 was designed for the 
Java 2 platform, it will not run on older Java VMs. To download the latest JDK or JRE, visit 
http://www.javasoft.com. 

• Does your OS run the Java VM correctly? - On Windows machines, the Java 2 VM only runs on 
Win32 machines, such as Windows 95/98, Windows NT, and Windows 2000. A Java 2 VM is not 
currently available for 16-bit Windows operating systems, such as Windows 3.x.  Solaris is the 
supported reference implementation for UNIX Java VMs. Although the JDK and JRE have been 
ported to other flavors of UNIX, not every one is supported. Also, some implementations may suffer 
from bugs. For more information about the JRE on your UNIX platform, visit 
http://www.javasoft.com. 

Problems loading documents 
The most common errors encountered in XML Pro involve problems with Validation, either opening a 
document that is invalid, or a problem with the DTD assigned to the document. 
 
• Is there an error in the DTD? - If your document has an associated DTD that contains an error, 

XML Pro will be unable to open the document. An error message indicates where in the DTD the 
problem can be found, by line number. This type of error message will allow you to review the DTD, 
and correct the error so that the document can open correctly. 

• Is the DTD invalid? - If the DTD associated with the document is not a valid DTD file, the document 
will not open. Instead an error will be generated, indicating the line in the DTD that contains the 
problem.  

• Is the document or DTD not well formed? - If the XML document or DTD you are opening is not 
well formed, XML Pro will not open the document. An error message indicating the error and the 
line containing the error will be generated.  

• Is the specified DTD missing? - If the DTD specified for the document is not in the specified 
location, XML Pro will not open the document. To correct the problem, either locate and copy the 
DTD to the proper location, or edit the XML file by had to remove the reference to the specified 
DTD. Also, if you specified a URL for the location of the DTD, it is possible that the URL is moved, 
missing, or unreachable. Try another URL, or try specifying a DTD on your machine’s hard drive 
instead. 

Once you have successfully loaded or created an XML document with an associated DTD in XML Pro, 
you can use the Validation feature to validate the XML file's contents against the DTD specification. If 
XML Pro encounters a problem during the validation process, the offending element will be highlighted, 
and an error will be generated. 
 
The errors that are generated from validation indicate the nature of the problem, and XML Pro will select 
the item causing the error within the document. This allows you to correct the problem, and then continue 
with the validation process. 
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Problems saving documents 
If you experience problems when saving documents, check for the following problems: 
 
• Is it a read-only file? - Make sure you are not saving to an existing, write-protected file. In 

Windows, right-click the file, select Properties, and ensure that the Read-only attribute is not 
selected. UNIX users should issue the command chmod +uw filename to enable writing to the file. 

• Is the document invalid? - If your document contains a DTD, you must validate it before saving to 
avoid possible errors. See Chapter 6 for more details on document validation. 

• Is the filesystem full?- If your drive is full, XML Pro will be unable to save files. Ensure that you 
have enough room, or switch to another filesystem. 

• Is it a read-only volume? - You can’t write to a volume that has been marked as read-only, or to a 
read-only device. Try saving on another volume or filesystem. 

• Are you saving to network drives without proper permissions? - It’s possible that you’ve tried to 
save to a network drive without permissions. Ensure you have proper permissions to save to the 
network drive, or try another folder or volume.  

Printing problems 
Because XML Pro is written in Java, it does not use standard print drivers like other software on your 
computer. Instead, XML Pro must create bitmap files of your document pages and send them directly to 
your printer. Because of this, you may have problems printing in XML Pro. This may happen if your 
printer doesn’t have enough memory, or if it uses specific print drivers. 
 
If you have difficulty printing, one possible workaround is to print your document to a file, and then try 
sending this file directly to your printer, or to another printer. Contact technical support for more details 
on your specific printing problem. 


